Re: [greenstone-users] Greenstone on Debian Sarge?

From jens wille
DateWed, 05 Jan 2005 22:27:07 +0100
Subject Re: [greenstone-users] Greenstone on Debian Sarge?
In-Reply-To (010520051950-4207-41DC450700025FA40000106F21603762239D0A990A9D0DD2020106-att-net)
[cc: greenstone-users@list.scms.waikato.ac.nz -- to let people know
that this solved your problem ;-)]

jon.brewer@att.net wrote:
> Thanks Jens!
>
> This was a perfect solution.
you're welcome!

> *********************************************
> Import complete
> *********************************************
:-)

> -------------- Original message from "Jens Wille"
> <j_wille@gmx.net>: --------------
>
>
>> hi!
>>
>>> In order to remedy I did as per FAQ remove
>>> gsdl/perllib/cpan/XML and gsdl/perllib/cpan/auto directories.
>>> I did install the required packages. Now I have this (below).
>>> Help?
>>>
>>> XML::Parser::Expat object version 2.34 does not match
>>> bootstrap parameter 2.27 at /usr/lib/perl/5.8/DynaLoader.pm
>>> line 245. Compilation failed in require at
>>> /usr/local/gsdl/perllib/cpan/perl-5.8/XML/Parser.pm line 14.
>>> BEGIN failed--compilation aborted at
>>> /usr/local/gsdl/perllib/cpan/perl-5.8/XML/Parser.pm line 18.
>>
>> as seems to me this is new with gsdl 2.52 (while the faq just
>> isn't updated yet), so you have to remove
>> gsdl/perllib/cpan/perl-5.8/XML and
>> gsdl/perllib/cpan/perl-5.8/auto instead.
>>
>> this works for me, though i'm not quite sure, whether it's
>> correct or what the reasons are.
>>
>> hth
>>
>> jens