Re: RE : [greenstone-devel] Frenc diacritics in item.files - Help:simplehelp

From Katherine Don
DateFri, 01 Dec 2006 13:49:34 +1300
Subject Re: RE : [greenstone-devel] Frenc diacritics in item.files - Help:simplehelp
In-Reply-To (A11793301D39D711A6850002A5EF77E108F34BB6-SIVALEXG017)
Hi Patrick

I have built a collection using your item files. It seemed to work for me.

A document displayed the table of contents, and displayed the image
underneath when you got to a page. Is this the image that didn't display
for you?

How are you building the collection? Just a straight complete rebuild?
Or are you trying to do incremental/minimal rebuilding?

I would try deleting the archives and index and building directories in
the collection, and rebuilding. Maybe some old stuff is still hanging
around?

Other than that, I don't know what to suggest, sorry.

Regards,
Katherine

HERNEBRING Patrick wrote:
> Hi Katherine
>
> We are using the GLI and the 2.71 version. The item.files are in "XML" style. I switched already to expert mode and don't get any error when the pagedimgplug is processing the item.files.
> If I suppress the diacritics in the item files, every thing is (generally) working well, but if there are some diacritics, the only problem will be that the images won't be displayed. (In our collection "images" can mean either [srcicon] or [screenicon], or [Docimage]) the navigator can't find the image and displays the small "red cross" instead. However, the TOC is displayed correctly (including the diacritics). The content of the metadatas file in the "archive" folder is the same, but the links to the images are pointing to a false HASH (ex: ".../index/assoc/HASH3fOb.dir/cover.jpg" instead of ".../index/assoc/HASH01b0.dir/cover.jpg"). Besides, for the same document, the HASH folders have not the same numbers in "/index/assoc/" and in "/archives/"...
>
> I join three item.files, the first one (e.g. agatanget.item) is working only if there are no diacritics inside. The second and the third will generate the same kind of problems, but even if there are no diacritics! I don't know why, it seams that there is no syntax error in them...)
> To be complete, I just add that I've noticed that the problem is the same for some HTML and PDF documents...
>
> Here is the cfg of the collection too...
>
> Thanks again and again...
>
> Regards
>
>
> Patrick Hernebring
>
> Fonds musical ancien - Num□risation
>
> Biblioth□que d'Etude et du Patrimoine
>
> Biblioth□que de Toulouse
>
> 1 rue de P□rigord, 31000 Toulouse
>
> T□l : 05 62 27 63 76
>