Re: [greenstone-users] import.pl failed

From Jean-Baptiste Soufron
DateMon, 09 Feb 2004 03:20:00 +0100
Subject Re: [greenstone-users] import.pl failed
In-Reply-To (4026E567-5C163FD3-cs-waikato-ac-nz)
Everything looks like working :)

thanks

Le lun 09/02/2004€ 15:41, Katherine Don a€crit :
> Hi
>
> From a previous posting to the mailing list:
>
> Both our prebuilt linux and mac os x greenstone distributions were
> built
> on machines that use perl 5.6, and the distributions contain a few
> binary perl modules.
>
> Install the perl "XML::Parser" natively for your system and get
> greenstone to use that instead of the one that comes with
> greenstone.
> You might have to remove the "gsdl/perllib/cpan/XML" and
> "gsdl/perllib/cpan/auto" directories so that perl doesn't look in
> there
> first.
>
>
> You can get expat from http://sourceforge.net/projects/expat/ and
> XML::Parser from http://search.cpan.org/~msergeant/XML-Parser-2.34/
> I think you need to install both of these.
>
> Hope this helps,
> Katherine Don
>
> Jean-Baptiste Soufron wrote:
>
> > I saw that I am not the only one to get this problem. When I use the
> > step-by-step way defined in the developer's guide, here is what I get :
> >
> > import.pl -removeold test2
> > Uncaught exception from user code:
> > Can't load
> > '/usr/local/gsdl/perllib/cpan/auto/XML/Parser/Expat/Expat.so' for module
> > XML::Parser::Expat:
> > /usr/local/gsdl/perllib/cpan/auto/XML/Parser/Expat/Expat.so: undefined
> > symbol: PL_sv_undef at
> > /usr/lib/perl5/5.8.1/i386-linux-thread-multi/DynaLoader.pm line 229.
> > at /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 14
> > Compilation failed in require at
> > /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 14.
> > BEGIN failed--compilation aborted at
> > /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 18.
> > Compilation failed in require at
> > /usr/local/gsdl/perllib/plugins/XMLPlug.pm line 36.
> > BEGIN failed--compilation aborted at
> > /usr/local/gsdl/perllib/plugins/XMLPlug.pm line 36.
> > Compilation failed in require at
> > /usr/local/gsdl/perllib/plugins/GAPlug.pm line 35.
> > BEGIN failed--compilation aborted at
> > /usr/local/gsdl/perllib/plugins/GAPlug.pm line 35.
> > Compilation failed in require at /usr/local/gsdl/perllib/plugin.pm line
> > 63.
> >
> > plugin::load_plugins('ARRAY(0x823e664)',2,'STDERR','import::FAILLOG')
> > called at /usr/local/gsdl/bin/script/import.pl line 403
> > import::main() called at /usr/local/gsdl/bin/script/import.pl
> > line 237
> >
> > So... what to do?
> > --
> > Jean-Baptiste Soufron, Doctorant
> > CNRS - CERSA Paris 2 Panthéon Assas
> >
> > http://soufron.free.fr
> >
> > icq : 1512744
> > msn : jbsoufron@hotmail.com
> > jabber : soufron
> >
> > _______________________________________________
> > greenstone-users mailing list
> > greenstone-users@list.scms.waikato.ac.nz
> > https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
--
Jean-Baptiste Soufron, Doctorant
CNRS - CERSA Paris 2 Pant€on Assas

http://soufron.free.fr

icq : 1512744
msn : jbsoufron@hotmail.com
jabber : soufron