Re: [greenstone-users] oaiserver curiosity

From Katherine Don
DateWed, 08 Mar 2006 14:31:52 +1300
Subject Re: [greenstone-users] oaiserver curiosity
In-Reply-To (4407B53D-6050906-cs-waikato-ac-nz)
Hi Arthur

I think I've fixed this. I've put some updated C++ files in
http://www.cs.waikato.ac.nz/~kjdon/greenstone/oaipatch/
Copy them into greenstone/src/oaiserver/
Then run 'make' and 'make install' in that directory.

Hopefully your incremental and assigned ids will now work.
Please let me know how you get on,

Regards,
Katherine

Michael Dewsnip wrote:
> Hi Arthur,
>
> This is definitely a bug -- values are compared with "HASH" half a dozen
> times in the oaiserver code! Unfortunately I don't know anything about
> this code so it's going to take a little bit of figuring out. Hopefully
> we'll get this sorted out before the next Greenstone release, however.
>
> Thanks for reporting this,
>
> Michael
>
>
>
> Arthur R. Belanger wrote:
>
>
>>Hello.
>>
>>I am running Greenstone 2.63 on a Red Hat 4 server.
>>
>>The oaiserver works well for my collections as long as I use OIDtype
>>hash on import. If I use incremental or assigned, the ListRecords
>>function does not return any records although the ListIdentifiers does
>>return all of the record identifiers. Is this by design or is it a
>>bug or have I missed something?
>>
>>Thanks very much for your help.
>>
>
>
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>