[greenstone-users] Release 2.83 for OS X

From Leo Riesthuis
DateWed Dec 30 22:26:15 2009
Subject [greenstone-users] Release 2.83 for OS X
In-Reply-To (3418F2E9738E4BBE8B39F33863A592A4-Qmotion)
Dear All,

After some more investigation I found the solution for my problem.

Apparently there are several Perl versions available in Snow Leopard. With
the following terminal command you can set version 5.8.9 to be used as
default by the system:

defaults write com.apple.versioner.perl Version 5.8.9

see man perl.

Greetings,

Leo Riesthuis

_____

From: greenstone-users-bounces@list.scms.waikato.ac.nz
[mailto:greenstone-users-bounces@list.scms.waikato.ac.nz] On Behalf Of Leo
Riesthuis
Sent: vrijdag 18 december 2009 20:08
To: greenstone-users@list.scms.waikato.ac.nz
Subject: [greenstone-users] Relase 2.83 for OS X

Dear All,

I have tried to install and run Greenstone release 2.83 on my Macbook with
Snow Leopard. I get problems with Perl version 5.10.

These problems persist even after installing bin-linux-perl-5.8.9.tar as
mentioned in the 2.83 release notes. The system complains about wrong
architecture at
/System/Library/Perl/5.10.0/darwin-thread-multi-2level/DynaLoader.pm line
207 at /Users/xxxx/Greenstone/perlib/cpan/perl-5.9/XLM/Parser.pm line 14

I have run setup.bash as mentioned but it seems to make no difference.

Greetings,

Leo Riesthuis

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://list.scms.waikato.ac.nz/mailman/private/greenstone-users/attachments/20091230/76ac0759/attachment.html