[greenstone-devel] Una duda

From Alexis Denis Martinez
DateWed, 22 Dec 2004 15:37:33 -0500
Subject [greenstone-devel] Una duda

Saludos cordiales,

 

Bueno tengo un problema serio, acabo de instalar la greenstone sobre Linux mandrake, y también sobre Windows y me sucede lo siguiente a partir del fichero de metadatos de Dublín cree mis propios metadatos y sobre Windows creo la colección sin problemas pero sobre Linux me da los siguientes errores

 

Comando: /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/bin/script/import.pl -gli -language es -collectdir /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/collect/ basededa

import.pl> Can't load '/usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/cpan/perl-5.8/auto/XML/Parser/Expat/Expat.so' for module XML::Parser::Expat: /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/cpan/perl-5.8/auto/XML/Parser/Expat/Expat.so: undefined symbol: PL_stack_sp at /usr/lib/perl5/5.8.3/i386-linux-thread-multi/DynaLoader.pm line 229.

import.pl>  at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/cpan/perl-5.8/XML/Parser.pm line 15

import.pl> Compilation failed in require at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/cpan/perl-5.8/XML/Parser.pm line 15.

import.pl> BEGIN failed--compilation aborted at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/cpan/perl-5.8/XML/Parser.pm line 27.

import.pl> Compilation failed in require at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/XMLParser.pm line 29.

import.pl> BEGIN failed--compilation aborted at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/XMLParser.pm line 29.

import.pl> Compilation failed in require at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/plugins/XMLPlug.pm line 36.

import.pl> BEGIN failed--compilation aborted at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/plugins/XMLPlug.pm line 36.

import.pl> Compilation failed in require at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/plugins/GAPlug.pm line 35.

import.pl> BEGIN failed--compilation aborted at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/plugins/GAPlug.pm line 35.

import.pl> Compilation failed in require at /usr/local/jakarta-tomcat-4.0.6/webapps/bvcitma/gsdl/perllib/plugin.pm line 67.

import.pl> El comando no se pudo ejecutar.

 

Les pido por favor si tienen una idea de lo que esta sucediendo me lo envíen, aunque me parece algún error en fichero Expat.so y lo demas es una cadena de errores

 

Sin más,

 

Muchas gracias

 

Alexis Denis Martínez

Especialista de Informática