[greenstone-users] Re: urgent problem please help

From Anupama of Greenstone Team
DateTue Feb 3 11:33:35 2009
Subject [greenstone-users] Re: urgent problem please help
In-Reply-To (4105c9810901310400hfb4731aqd97b77169d211473-mail-gmail-com)
Hello Amin,

Yes, we also noticed this yesterday to our horror. It had to do with the
changes that I and another developer had committed on Friday. We forgot
to commit one additional file along with it.

The way we fixed it in our situation is by doing the following, will you
also try it:

1. download the following file from svn
http://svn.greenstone.org/greenstone3/trunk/web/ui/xslt/preProcess.xsl

2. place it in your greenstone3 installation folder's web/ui/xslt
folder. It should replace the older preProcess.xsl file already there.

3. Do not forget to update the following 3 files from svn:

a. Replace your
greenstone3/src/java/org/greenstone/gsdl3/core/TransformingReceptionist.java
with
http://svn.greenstone.org/greenstone3/trunk/src/java/org/greenstone/gsdl3/core/TransformingReceptionist.java

b. Replace your
greenstone3/src/java/org/greenstone/gsdl3/util/XMLTransformer.java with
http://svn.greenstone.org/greenstone3/trunk/src/java/org/greenstone/gsdl3/util/XMLTransformer.java

c. Replace your
greenstone3/src/java/org/greenstone/gsdl3/util/XMLConverter.java with
http://svn.greenstone.org/greenstone3/trunk/src/java/org/greenstone/gsdl3/util/XMLConverter.java

4. Finally, make sure to recompile everything by stopping your server,
going into your greenstone3 installation folder and typing:
> ant compile-core

Restart the server and try it out now.
Did it work? Tell us if it didn't.

Thanks,
Anupama


Amin Hedjazi wrote:
> hello
> i have a problem here
> i have downloaded the new greenstone3 from the svn and run ant prepare
> install like allwayes
> but when trying to load the library i get the error code below
>
>
> The following error occurred:
>
> couldn't create transformer object
>
> javax.xml.transform.TransformerConfigurationException:
> javax.xml.transform.TransformerException: java.lang.NullPointerException
>
>
> i havent changed any thing this is the way i always doned it before
>
> but this time i am having problems runing the library
>
> am i doing some thing wrong or is there a bug here
>
> some one please help
>
> i am about to run my libary in a poblic server i have been working on it
> for so long know
>
> and this happend .
>
> thanks
>
>
>