[greenstone-users] the greenstone library path in GLI

From Anupama of Greenstone Team
DateTue Mar 9 16:59:57 2010
Subject [greenstone-users] the greenstone library path in GLI
In-Reply-To (276393-25191-qm-web27505-mail-ukl-yahoo-com)
Hi Emmanuel,

Did the server not shutdown properly at some point (was Ctrl-C pressed
for instance, instead of GLI and the Greenstone Server Interface exiting
normally)?

Here's 3 things I would try, after shutting down both GLI and the web
server:

A.1. In your Greenstone installation folder, delete the glisite.cfg file.

2. Now try again by restarting GLI (which should start the Greenstone
web server).


If that didn't work, then exit GLI and shut down the server again (in
case GLI didn't shut it down), then REPEAT STEP A1 above, followed by
steps 1 and 2 below:

B.1. Open GLI and go to Preferences>Connection and manually set the path
to where the web server usually serves your pages. It will be something
like:
http://localhost:8282/greenstone/cgi-bin/library.cgi

But use the host and port number that you've seen your web server use so
far.


If that didn't work either, one other thing you could try is (after
shutting down GLI and the web server again and deleting glisite.cfg by
repeating step A1):

C.1. Go to your GLI user folder (it's the hidden ".gli" folder in your
Linux user directory; on Windows your GLI user folder will be located in
your user's Application Data folder).

Open the file config.xml. Edit the general.library_url_gs2 property by
setting it manually (the test is to see if this works):
<Argument
name="general.library_url_gs2">http://localhost:8282/greenstone/cgi-bin/library.cgi</Argument>


You'd want to type the hostname and portname your Greenstone web server
usually uses.

2. Restart GLI (which should start the webserver). Does the preview
button work now?


If any of the above worked (try A to C in the given order), can you
write back to tell us which one worked? Can you also remember what last
happened that it now no longer contains the Greenstone library path in
the preview URL? For example, was GLI not shut down properly, did it
crash last time?

Regards,
Anupama


Emmanuel NGOI wrote:
> Dear users,
> I have some difficulties to set the greenstone library path in GLI to connect to the correct web server in order to preview collections.
> I went to file>Preferences>Connection tab and setting
> the value of the Greenstone Web Path field but when I start the GSDL there is no path in connection tab.
> could somebody help me?
> Thank you very much.
> Best regards
> Emma
>
>
>
>
>
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users