[greenstone-users] Greenstone 2.83

From Anupama of Greenstone Team
DateTue Apr 20 16:02:33 2010
Subject [greenstone-users] Greenstone 2.83
In-Reply-To (fc2ecba71876e4-4bbbc736-hawaii-edu)
Hi Peter,

Can you try the following:

1. Close the Greenstone Librarian Interface (GLI).

2. Check that the server is indeed not running. Open a web browser and
type the localhost URL that used to work previously in there
(localhost:1025) and check that nothing useful happens.

3. Using your file system browser such as Windows Explorer on Windows,
go into your top level greenstone installation folder and delete the
following files IF they exist:
- glisite.cfg (but don't delete glisite.cfg.in)
- llssite.cfg (but don't delete llssite.cfg.in)

4. Now try running just the Greenstone server application, instead of
running GLI:
- On WINDOWS you would run it through your Start Menu > Greenstone 2.83
> (Greenstone) server
- On LINUX and MAC you would run this by using a terminal to cd into
your Greenstone installation directory and then executing the line:
./gs2-server.sh

Running the Greenstone server application should show up a little white
dialog with an Enter Library button in the centre. Press it and it
should start up a browser window and hopefully take you to the
greenstone home page.

5. If the above worked, close the Greenstone server application. Now run
GLI and see whether upon running it, it also opens an instance of that
same Greenstone server application (the little white dialog).


Could you tell me if the above worked, and IF not, could you write us:
- at which step things failed and
- what operating system you are working on
- at the END of having attempted all the above steps, new versions of
the files glisite.cfg and llssite.cfg mentioned in step 3 would have
been regenerated. Could you send me the regenerated ones?

Regards,
Anupama


Everett Kanehiro wrote:
> Dear Sir or Madam:
>
> Could you please help me to resolve a problem? I am trying to complete
> one of the Greenstone tutorials (Building a Multimedia Collection). I
> had just rebuilt the collection. When I tried to preview, the following
> message appeared (I am using Firefox 3.5.9). The same message appears
> when I try to access any collection I created in prior tutorials. It
> was functioning normally until mid-tutorial.
>
> I have tried rebooting the computer and restarting the Librarian Interface.
>
> How can I establish a connection to the localhost so that I can
> proceed? Thank you.
>
> Peter Kanehiro
>
>
> Unable to connect
> Firefox can't establish a connection to the server at localhost:1025.
> * The site could be temporarily unavailable or too busy. Try again
> in a few
> moments.
> * If you are unable to load any pages, check your computer's network
> connection.
> * If your computer or network is protected by a firewall or proxy,
> make sure
> that Firefox is permitted to access the Web.
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users