[greenstone-users] Regarding client-gli installation

From Anupama of Greenstone Team
DateThu Apr 22 18:38:28 2010
Subject [greenstone-users] Regarding client-gli installation
In-Reply-To (u2t7181b771004202136o7b04e87at4d7979d0e52dd50d-mail-gmail-com)
Hi Ravi,

I'm at a loss. There's only a few things that come to my mind to
double-check:

1) What is the *first* line of your cgi-bin/gliserver.pl file located
inside your *server* machine's Greenstone installation?
=> Please write this in your response message.

Can you also include what operating system your server is running on? I
know your client is running on Windows.


2. Does your gliserver.pl (on the *remote* machine with the Greenstone
server) have its access permissions set correctly so that the public can
access it?

You may have already gone over this in the instructions, but on your
*client* machine, try to access the gliserver.pl page using a web-browser:

a) Once more, visit
http://lib.lnmiit.ac.in:8282/Greenstone/cgi-bin/gliserver.pl?cmd=check-installation

b) Then try visiting:
http://lib.lnmiit.ac.in:8282/Greenstone/cgi-bin/gliserver.pl?cmd=greenstone-server-version&ts=1271755140171&un=<your
greenstone collection's user name>&pw=<your greenstone collection's
password (unencrypted)>


Did the second URL work too? (You could probably try leaving out the
&ts=<long number> bit in the URL, since that's the timestamp)

What is the output to the browser screen?
=> Please send that in your next e-mail. (Just copy and paste the text
from the browser into your message.)


3) On the server machine, make sure the web server has allowed access
from all connections:

If your Greenstone server is running on Windows, then that comes with 2
web servers: local library and an apache-httpd, you want to use the
latter by renaming server.exe to server.unused or something. Linux and
Mac just have the apache-httpd server.

If you are using the apache-httpd server that comes with
Windows/Linux/Mac, then when you launch the Greenstone Server Interface
(GSI) dialog by running gs2-server.bat from your *DOS( prompt (from your
Greenstone installation folder). In the GSI dialog, go to the File >
Settings menu and tick the "Allow external connections" checkbox.
Restart the server by clicking on the dialog's central button, and make
a note of any changes in port number.

Now run the client-GLI again and see whether you can access the
gliserver.pl URL through it. And tell me whether you can or cannot do so.

The more information you give me, the more you help me to work out
what's happening on your machine.

Thanks,
Anupama

ravi bhushan wrote:
> Every stages are working properly .There is no problem in that. In the
> last step,it is written that run client-gli.bat but,when i am running
> this, it is giving error like i have attached images in the previous mail.
>
> On Tue, Apr 20, 2010 at 9:48 PM, Anupama of Greenstone Team
> <greenstone_team@cs.waikato.ac.nz
> <mailto:greenstone_team@cs.waikato.ac.nz>> wrote:
>
> Hi Ravi,
>
> I can't work out from your message whether you first followed the
> instructions at
> http://wiki.greenstone.org/wiki/index.php/Remote_Greenstone
>
> Did every step in the above instructions work for you? If not, where
> did things go wrong? Those instructions really need to be carried
> out in order for Remote Greenstone to work properly. They contain
> little tests at each stage as checkpoints that things are working.
> If any of those steps fail, other things may go wrong -- which would
> be harder to diagnose.
>
> Please write back to tell me whether you've already followed the
> steps on that wiki page and if everything succeeded.
>
> Also, you may need to undo the changes you made to findgsdl.bat so
> that it affect the functioning of any other part of greenstone.
>
>
> Regards,
> Anupama
>
>
> ravi bhushan wrote:
>
> After entering the url in client-gli,I am attaching the image
> showing the error message.
>
> On Tue, Apr 20, 2010 at 10:01 AM, Anupama of Greenstone Team
> <greenstone_team@cs.waikato.ac.nz
> <mailto:greenstone_team@cs.waikato.ac.nz>
> <mailto:greenstone_team@cs.waikato.ac.nz
> <mailto:greenstone_team@cs.waikato.ac.nz>>> wrote:
>
> Hi Ravi,
>
> This is in response to the 3 related e-mails you sent recently on
> the topic of getting the client-gli to work with the remote
> Greenstone server.
>
>
> 1. > Can you please give me step-by-step procedure to install
> client-gli on windows platform.
>
> Please see the instructions at
> http://wiki.greenstone.org/wiki/index.php/Remote_Greenstone
> It is quite important that you set up the remote Greenstone
> correctly, so do go through the page and make sure that the
> tests at
> various stages work.
>
> 2. > I have only set the "gsdl path" in
>
> > "findgsdl.bat" mannually and i have added on environment
> variale
> > "JAVA_HOME" which is the address of java in the greenstone
> folder.
>
> You shouldn't have to do that. findgsdl.bat is used by GLI for
> finding Greenstone on the *same* machine as that which GLI is
> running on. It can not find your Greenstone server if this is
> installed on a remote machine to the one you are running
> client-GLI
> from.
>
> Instead, the file you would be altering in accordance with the
> instructions at
> http://wiki.greenstone.org/wiki/index.php/Remote_Greenstone,
> is in
> cgi-bin/gsdlsite.cfg. But please see the wiki page for the
> details.
>
> 3. In a later e-mail you wrote:
> > When i am building collection through client-gli, I am
> getting the
> > error when we click on "complete rebuild" or "minimal
> rebuild"
> which is
> > attached with this mail.
>
> And you also wrote:
> > After gather, i want minimal rebuild of collection,but it
> is giving
> > error like:
> > "An error has occured on the remote Greenstone server while
> > performing this operation
>
> These issues may perhaps have been influenced by the
> procedure you
> followed in setting up your remote Greenstone server. If you
> could
> first go through the instructions at
> http://wiki.greenstone.org/wiki/index.php/Remote_Greenstone
> (or tell
> me if you had already done so, so that I know whether these
> problems
> are indeed independent of your remote Greenstone setup), and
> see if
> these problems continue to appear.
>
> Regards,
> Anupama
>
>
> ravi bhushan wrote:
>
>
> Hi,
>
> I want to install client-gli on windows platform.I have
> installed that but,I am getting some error.I have only
> set the
> "gsdl path" in "findgsdl.bat" mannually and i have added on
> environment variale "JAVA_HOME" which is the address of
> java in
> the greenstone folder.
>
>
> I am attatching image which is showing the error messages.Can
> you please give me step-by-step procedure to install
> client-gli
> on windows platform.
>
>
> Thanks
> ------------------------------------------------------------------------
>
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> greenstone-users mailing list
> greenstone-users@list.scms.waikato.ac.nz
> <mailto:greenstone-users@list.scms.waikato.ac.nz>
> <mailto:greenstone-users@list.scms.waikato.ac.nz
> <mailto:greenstone-users@list.scms.waikato.ac.nz>>
>
>
> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>
>
>
> ------------------------------------------------------------------------
>
>
>