[greenstone-users] Cross Collection "Infection"

From Gavin Spomer
DateWed Dec 10 08:17:40 2008
Subject [greenstone-users] Cross Collection "Infection"
In-Reply-To (493C857A-50304-cs-waikato-ac-nz)
Wow. This was a long time ago. ;)

I'm still using Greenstone 2.72. Currently, the problem has either corrected itself or no image collections have been built by our archivist. I would test, but am just swamped right now. When the problem exists, building an image collection only affects the the paged image collection. When building the paged image collection, it does not affect the image collection. It's like the image collections are ganging up on the paged image collection because it's different. LOL! ;)

- Gavin

>>> Katherine Don <kjdon@cs.waikato.ac.nz> 12/07/08 6:24 PM >>>
Hi there

Weird! What versions of Greenstone are you using?
Gavin, when you build the image collections, do they affect any of the other image collections? And if you build the pagedimage collection, does it not affect the image collections?

James, you are having a paged image collection affecting an image collection?

Are your thumbnails all called thumbnail.jpg? The images that are affecting the different collections, do they have the same name?

In Greenstone 2.81 the thumbnails have the original file name as part of their name, so hopefully this won't happen any more. (I hope you are not seeing this in 2.81!)

Cheers,
Katherine

James Fournie wrote:I am having this problem as well, and so I thought I'd bump this topic
in case Gavin has solved it or anyone has any feedback on it.

I have several paged image collections and a photo collection. I
should note that the paged image collections are heavily customized
with HTML and CSS. When I search the (uncustomized) photo collection,
I see thumbnails from the paged image collections in the search
results, and those thumbnail photos are in the photo collection's
folder under index/assoc/HASH0122.dir/thumbnail.gif -- these files
themselves are the wrong thumbnails, but only the thumbnails seem
wrong (the full size and screenview seem fine).

I suspect there is something going wrong when the thumbnails are
generated during collection building, maybe with the tmp folder. but
I'm not sure exactly what's causing the cross pollination.

~James

On Fri, Sep 21, 2007 at 2:13 PM, Gavin Spomer <spomerg@cwu.edu> ( mailto:spomerg@cwu.edu ) wrote:


I have a problem that has me totally stumped. On our Greenstone server we have 8 image collections and 1 paged-image collection. When building any of the image collections, it affects the paged-image collection in the following way: some, but not all, of the [ex.thumbicon]'s my SearchVList show thumbnail images from the image collection that was built, instead of the correct thumbnail images from the paged-image collection. Even more vexing, when I right-click on one of the "invading" thumbnails and select "View image", the resulting url shows that the thumbnail is in one of the paged-image HASH subdirectories!! Oddly enough, the VList for my browsing classifiers is unaffected.

If I rebuild my paged-image collection, the problem gets fixed. But this is obviously not a long term solution. I don't want to have to rebuild my paged-image collection after every time I build one of my image collections.

This is quite disconcerting and doesn't make any sense to me whatsoever. If I have one collection open in the GLI, why should it have ANY effect on another collection?

I'm thoroughly perplexed. What am I missing?

Gavin Spomer
Systems Programmer
Brooks Library
Central Washington University


_______________________________________________
greenstone-users mailing listgreenstone-users@list.scms.waikato.ac.nzhttps://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users

_______________________________________________
greenstone-users mailing listgreenstone-users@list.scms.waikato.ac.nzhttps://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users