Re: [greenstone-users] no gli display of values for customized metadata set

From Margaret Graham
DateFri, 23 Jul 2004 07:30:19 -0400
Subject Re: [greenstone-users] no gli display of values for customized metadata set
In-Reply-To (40FDA1CB-405-cs-waikato-ac-nz)
Katherine,

Thanks for responding to my query.

I'm using 2.50 on a Windows platform. In the Enrich view, the values for
the newly created elements don't display in the metadata list for the
current document - where they would show on the line with the DC
element. Even though they don't display, we've found they are written
to the doc.xml file.

Whether the values show up in the list of previous values was
intermittent - I didn't know about the remember_values='true' statement
which sounds like it will retain previous values but I'm not sure it
will affect the display in the metadata list for the current document.
I'll try adding it to the .mds file and see what happens.

Thank you for your help!

Margaret Graham


--
Margaret Graham
Digital Project Archivist
Archives & Special Collections
Drexel University College of Medicine
http://med.library.drexel.edu/archives/
215.842.4700
mmg24@drexel.edu

Katherine Don wrote:
> Hi Margaret
>
> When you say that the metadata values don't show up, what do you mean?
> If you enter the value in the Enrich view, does it not show up in the
> metadata list for that document?
> What version of Greenstone are you using?
>
> I have just tried adding new elements to the dls metadata set, both by
> using metadata sets->edit set, and also editing the dls.mds file in the
> collection. In both cases, I could add values to documents, and they
> would display both in the metadata list for the current document, and
> also in the previous values list for the new metadata.
>
> However, if I shut down the GLI and restarted it, while the metadata was
> still visible for the document, the previous values did not display all
> the values I had entered. If I clicked around documents, the values
> would appear, one by one.
> To solve this I had to edit the dls.mds file, and add
> remember_values='true' to the new elements. eg
> <Element name="Name" occurances="4" remember_values="true">
> <Attribute language="en" name="identifier">Name</Attribute>
> </Element>
>
> Does this sound like the problem you are having?
> Note, I am using our development version of Greenstone, which should be
> similar to version 2.51.
>
>
> Regards,
> Katherine Don
>
>
> Margaret Graham wrote:
>
>> Folks -
>>
>> We are working with the Librarian Interface and have customized the
>> existing Dublin Core metadata set by adding elements to the dc.mds
>> file. Some elements were added through the Librarian Interface and
>> others were added directly to the file. While the new elements appear
>> in the Librarian Interface, when we add a value to the element in the
>> Enrich view, the value does not show up.
>>
>> The value does show in the collection metadata.xml file and in the
>> doc.xml file in the hash directory. When the collection is built and
>> the added but invisible value is searched for, the corresponding item
>> is found. There does not seem to be a problem adding values to the
>> pre-existing Dublin Core elements.
>>
>> We're looking for help in how to make the values for the new elements
>> display in the GLI. While we can work on blind faith that we're
>> entering data correctly, visual confirmation would be better!
>>
>> Any and all suggestions appreciated!
>>
>> Margaret Graham
>>
>>
>>
>