[greenstone-devel] FW: Fatal build problem with undefined HASH reference

From Peter Hollings
DateThu Mar 12 06:35:02 2009
Subject [greenstone-devel] FW: Fatal build problem with undefined HASH reference
Forgive the cross-post, but I have not gotten any help on the users' list.
I should note that I had built this library many times until I changed from
AZ Compact sort to Generic. That is probably part of the cause of my
problem.

Thanks,

Peter Hollings

From: Peter Hollings [mailto:phollings@ipt.org]
Sent: Tuesday, March 10, 2009 6:33 PM
To: 'greenstone-users@list.scms.waikato.ac.nz'
Subject: Fatal build problem with undefined HASH reference

I have a perplexing problem that is occurring near the end of the GLI build
process. It affects only one of the collection files - the last one to be
processed. I get the following message in the log:

"buildcol.pl> GAPlug: processing HASH01d0.dirdoc.xml

buildcol.pl> Can't use an undefined value as a HASH reference at C:Program
FilesGreenstone3gs2buildperllibclassifyGenericList.pm line 540.

buildcol.pl> Command failed."

I tried removing the archive files and re-importing the collection to no
avail. The problem occurs consistently after re-starting GLI, etc. In other
words, it occurs every time I attempt to build the collection. I am using
GLI 3.03 on Win XP.

Please help! This is a fatal error that aborts the build process and
prevents me from viewing the collection.

Peter Hollings

phollings@ipt.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://list.scms.waikato.ac.nz/mailman/private/greenstone-devel/attachments/20090311/c752a790/attachment.html