[greenstone-devel] GLI with javac 1.5.0

From Emanuel Dejanu / Simple Words
DateWed, 3 Nov 2004 17:31:28 +0200
Subject [greenstone-devel] GLI with javac 1.5.0
Hi,

I can not compile the GLI with JDK 1.5.
The problem is with "enum" variabile that is now a keyword.

Rename enum to _enum in

srcorggreenstonegathererguimetaauditFilter.java solve this problem.

But I still get this error:

src/org/greenstone/gatherer/util/ApplyXSLT.java:59: package
org.apache.xalan.processor does not exist
t_factory =
org.apache.xalan.processor.TransformerFactoryImpl.newInstance();


and lots of notes:

Note: src/org/greenstone/gatherer/checklist/CheckList.java uses unchecked or
unsafe operations.
Note: Recompile with -Xlint:unchecked for details.


Best regards,

Emanuel Dejanu