Re: RE : RE : RE : RE : [greenstone-devel] Frenc diacritics in item.files - Help:simplehelp

From Michael Dewsnip
DateThu, 21 Dec 2006 15:11:06 +1300
Subject Re: RE : RE : RE : RE : [greenstone-devel] Frenc diacritics in item.files - Help:simplehelp
In-Reply-To (A11793301D39D711A6850002A5EF77E108F34BD1-SIVALEXG017)
Hi Patrick,

Thanks for the extra information. We still can't reproduce your problem
here though; could you please send us (off-list) a small collection that
exhibits the problem (import, etc and metadata directories)?

Regards,

Michael

HERNEBRING Patrick wrote:

> Hi Katherine,
>
> I found out a way to avoid this problem without knowing why. I hope
> this information will help. (I've already upgraded to 2.72).
>
> If the GLI is in english (and not in french) _and_ if in the
> configuration of the arguments of the "browsing classifiers" the
> metadata (and the sort) are in English (and not in French), the
> building process will work correctly. Otherwise□
>
> Have a good holiday,
>
> Regards,
>
> Patrick Hernebring
>
> Fonds musical ancien - Num□risation
>
> Biblioth□que d'Etude et du Patrimoine
>
> Biblioth□que de Toulouse
>
> 1 rue de P□rigord, 31000 Toulouse
>
> T□l : 05 62 27 63 76
>
> -----Message d'origine-----
> De : Katherine Don [mailto:kjdon@cs.waikato.ac.nz]
> Envoy□ : mardi 12 d□cembre 2006 22:32
> □ : HERNEBRING Patrick
> Objet : Re: RE : RE : RE : [greenstone-devel] Frenc diacritics in
> item.files - Help:simplehelp
>
> Hi Patrick
>
> Sorry for not replying sooner. This sounds really weird, and I can't
>
> replicate it here. Its particularly weird that the demo collection
>
> creates fine, but your other one doesn't.
>
> A couple of suggestions (unless it has miraculously fixed itself already):
>
> * Create a new collection, base it on your existing one. Then copy all
>
> the documents from the old one into the new one. Then build this. Does
>
> the index dir get created here?
>
> * Create a new collection, base it on the default. Copy the documents in
>
> from old collection and build - does the index dir get created this time?
>
> * We will be releasing 2.72 either today or tomorrow - try with this new
>
> version, just in case something has changed.
>
> The language of GLI shouldn't affect the metadata or classifiers, so I
>
> am not sure what is happening there.
>
> If you are still getting this problem, even after upgrading to 2.72,
>
> please create a small demo collection, with say 3 documents, including
>
> their metadata. And send it to me - I need the import, etc and metadata
>
> directories.
>
> And I will try to build it here.
>
> What OS are you using?
>
> Note that I will be going on holiday this Friday, and won't be back
>
> until 8th Jan.
>
> Regards,
>
> Katherine
>
> HERNEBRING Patrick wrote:
>
>> Katherine,
>
>>
>
>> I really don't understand what is happening.
>
>>
>
>> If I first delete the "index" directory and build the collection with gli
>
>> set up in French (in the preferences), the "index" directory won't be
>
>> created. But, if I change the name of the "buiding" directory into
> "index",
>
>> everything will be OK. If I use the gli set in English, the "index"
>
>> directory will be created, but the classifiers won't work (the lists will
>
>> remain empty).
>
>>
>
>> If I try to build the demo collection (with the gli set up in
> french), every
>
>> thing is OK...
>
>>
>
>> I can't find any messages concerning the impossibility of deleting
> "index"
>
>> (here are the log history in English and in French of the building of our
>
>> test collection
>
>>
>
>> Regards,
>
>>
>
>> Patrick
>
>>
>
>> Patrick Hernebring
>
>>
>
>> Fonds musical ancien - Num□risation
>
>>
>
>> Biblioth□que d'Etude et du Patrimoine
>
>>
>
>> Biblioth□que de Toulouse
>
>>
>
>> 1 rue de P□rigord, 31000 Toulouse
>
>>
>
>> T□l : 05 62 27 63 76
>
>>
>
>>
>
>> -----Message d'origine-----
>
>> De : Katherine Don [mailto:kjdon@cs.waikato.ac.nz]
>
>> Envoy□ : lundi 4 d□cembre 2006 02:45
>
>> □ : HERNEBRING Patrick
>
>> Objet : Re: RE : RE : [greenstone-devel] Frenc diacritics in item.files -
>
>> Help:simplehelp
>
>>
>
>> When you build with the GLI, it should build the collection into
>
>> building, then delete index and rename building to index.
>
>> Are you getting errors about not being able to delete index?
>
>> Try deleting (or renaming) the index directory, then rebuilding. Do you
>
>> get a new index directory with everything in it?
>
>>
>
>> Cheers,
>
>> Katherine
>
>>
>
>> HERNEBRING Patrick wrote:
>
>>
>
>>>Katherine,
>
>>>
>
>>>Finally, it appears that this problem has nothing to do with
> diacritics, I
>
>>
>
>> misunderstand it (sorry !). Actually, it seems that the "assoc" folder is
>
>> created only in "building" but not in "index" which remains the same
> after a
>
>> new rebuild... (if I copy it manually in "index", every thing is OK)
>
>>
>
>>>Any suggestions ?
>
>>>
>
>>>Regards
>
>>>Patrick
>
>>>
>
>>>Patrick Hernebring
>
>>>
>
>>>Fonds musical ancien - Num□risation
>
>>>
>
>>>Biblioth□que d'Etude et du Patrimoine
>
>>>
>
>>>Biblioth□que de Toulouse
>
>>>
>
>>>1 rue de P□rigord, 31000 Toulouse
>
>>>
>
>>>T□l : 05 62 27 63 76
>
>>>
>
>>>
>
>>
>
>>
>
>>
>
>------------------------------------------------------------------------
>
>_______________________________________________
>greenstone-devel mailing list
>greenstone-devel@list.scms.waikato.ac.nz
>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-devel
>
>