RE: [greenstone-users] Subject Browse Help

From Victor T. Jones, Jr.
DateFri, 24 Mar 2006 17:17:35 -0500
Subject RE: [greenstone-users] Subject Browse Help
In-Reply-To (20060323223922-GW32435-matai-cs-waikato-ac-nz)
John,

Thanks for the reply. I didn't have a CL2Vlist statement, so
I put one in and played with the results just a little. That
works...partially. I would like the results to forward to
the web pages I have already created rather than to the
resulting webpages created on the fly by Greenstone.

My format info is as follows for CL2VList:
<td valign=top>[link][icon][/link]</td>
<td
valign=top>[ex.srclink]{Or}{[ex.thumbicon],[ex.srcicon]}[ex.
/srclink]</td> <td valign=top>[highlight][weblink]
{Or}{[dls.Title],[dc.Title],[ex.Title],Untitled}
[/weblink][/highlight]{If}{[ex.Source],<br><i>([ex.Source])<
/i>}</td>

When I browse the Subject category, I get the Subject
Headings, and if I click on the icon by the subject, I go to
a list of the documents. [This is fine, but is there a way
to hyperlink the subject headings, too?]

When I click on the icons for the documents, I am forwarded
to the pages generated by Greenstone. When I click on the
hyperlink for the title of a document, I am forwarded to the
page on my web server [the later portion is what I want].

How can I get to the pages on my web server by clicking the
icon? If I replace [link][icon][/link] with
[weblink]...[/weblink], I can no longer access the documents
from the Subject Browse page. In other words, I cannot click
on the bookshelf icon in the Subject browse to see the list
of documents for a particular subject.

Thanks again,
Victor


---
Victor T. Jones, Jr.
Local History and Genealogy Librarian
New Bern-Craven County Public Library
400 Johnson Street
New Bern, NC 28560-4098

Phone: (252) 638-7808 Fax: (252) 638-7817
E-mail: vjones@cpclib.org
Web: http://newbern.cpclib.org/

Opinions expressed in this communication are mine and do not
necessarily represent the opinions of the library.

-----Original Message-----
From: John R. McPherson [mailto:jrm21@cs.waikato.ac.nz]
Sent: Thursday, March 23, 2006 5:39 PM
To: Victor T. Jones, Jr.
Cc: greenstone-users@list.scms.waikato.ac.nz
Subject: Re: [greenstone-users] Subject Browse Help


On Thu, Mar 23, 2006 at 05:32:22PM -0500, Victor T. Jones,
Jr. wrote:
> I have been playing with Greenstone for the past week, and
> I'm having trouble creating a subject browse for my
> collection. I have some questions that I hope someone can
> answer.

> When I go to the collection
> (http://newbern.cpclib.org/gsdl/cgi-bin/library.exe and it
> is the Craven County Digital History Exhibit) the subject
> headings are there, but I do not have a link to the
> documents (individual webpages). The other selections
> (Title, Source, Date) all return links to the original
html
> file. Does anyone know why, or what I'm doing wrong?

Hi,
this would suggest that one of the formatting strings is
wrong.
Since it is the 2nd classfier (after titles), I'd suggest
that
your "format CL2VList" statement is wrong (assuming you have
one).
It looks like you've put in an [icon] to get the image, but
not
the [link]...[/link] tags to tell it to link to the
documents.

John