Fwd: [greenstone-users] GLI Java problem in Ubuntu

From John Rowe
DateWed, 30 Nov 2005 16:05:44 +1300
Subject Fwd: [greenstone-users] GLI Java problem in Ubuntu
In-Reply-To (A2F8BCD9-BB2D-4E3E-9DBD-414542E0D806-dlconsulting-co-nz)
Sorry, my reply follows.

Begin forwarded message:

> From: John Rowe <johnr@dlconsulting.co.nz>
> Date: 30 November 2005 11:21:54 AM
> To: Jes=FAs Tramullas <tramullas@unizar.es>
> Subject: Re: [greenstone-users] GLI Java problem in Ubuntu
> Reply-To: greenstone-users@list.scms.waikato.ac.nz
>
> It should work just fine on the Sun Java runtime, instructions for =

> installation are on the Ubuntu wiki at:
>
> https://wiki.ubuntu.com/RestrictedFormats#head- =

> e2ebd70ede0e3eb2117ffbd618d2295dd1540dca and
> https://wiki.ubuntu.com/Java?highlight=3D%28sun%29%7C%28java%29
>
> To make sure you are running Sun's Java you may need to add the =

> java binaries directory to your path. This should not interfere =

> with OpenOffice's operation. If you do have problems running =

> OpenOffice with sun java installed then you can change the gli =

> startup script to point to the Sun java but leave it out of your path.
>
> Cheers,
> John Rowe
>
> DL Consulting
> Greenstone Digital Library and Digitisation Specialists
> contact@dlconsulting.co.nz
> www.dlconsulting.co.nz
>
> On 30/11/2005, at 10:35 AM, Jes=FAs Tramullas wrote:
>
>> Dear friends:
>>
>> We're working with gsdl 2.62 and GLI over Ubuntu Linux with Sun =

>> JRE v1.5_05. We had some problems with Ubuntu 5.04, resolved by =

>> changing the Perl XML parser as related in http:// =

>> www.greenstone.org/cgi-bin/library?e=3Dp-en-faq- =

>> utfZz-8&a=3Dp&p=3Dfaqbuild#33 and all works fine.
>>
>> Upgrading the system to Ubuntu 5.10, the upgrade incorporates GNU =

>> Java environment, necessary to work with OpenOffice Base 2.0. But =

>> when we try to work with GLI, we get a lot of errors, and GLI =

>> doesn't start. We can confirm that the Java environment (java - =

>> version) is GNU Java. So, we must uninstall GNU Java in order to =

>> work with GLI (then, Java environment changes to Sun JRE 1.5_05), =

>> but then we lost OpenOffice Base program and funcionality.
>>
>> We tried to compile GLI with makegli.sh and GNU Java, but doesn't =

>> work.
>>
>> We'll try to change the default Java machine... any other idea?
>>
>> Cheers,
>>
>> Jes=FAs
>> -- =

>>
>> "Nunca arriada la bandera"
>> Ernest Shackleton
>>
>> --#-----------------------------------------------------------------
>> Dr. Jes=FAs Tramullas
>> Depto. Ciencias de la Documentaci=F3n | Dept. of Information Sciences
>> Universidad de Zaragoza
>> jesus@tramullas.com | tramullas@unizar.es
>> http://tramullas.com
>> -----------------------------------------------------------------#--
>>
>>
>> _______________________________________________
>> greenstone-users mailing list
>> greenstone-users@list.scms.waikato.ac.nz
>> https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://list.scms.waikato.ac.nz/mailman/private/greenstone-users/attac=
hments/20051130/c882c08d/attachment.html