Re: [greenstone-users] Unable to delete indexes

From Michael Dewsnip
DateThu, 16 Dec 2004 11:11:31 +1300
Subject Re: [greenstone-users] Unable to delete indexes
In-Reply-To (Pine-LNX-4-44-0412081305220-26789-100000-fornax-it-iitb-ac-in)
Hi,

This is a nasty problem that has been around for a while but proven
difficult to fully nail down. It has a number of causes, all related to
files in the index directory of the collection being held open. Some
possibilities are:

- The Local Library server has not closed all its open files when asked
to release a collection.
- The GLI has tried to delete the index folder of the collection before
the Local Library server has finished releasing it.

There isn't anything you can do about these. Fixing these problems is
high up on our "to do" list, and should happen before the next release.

There are also some things outside of our control that can cause the error:

- You have a window open showing the contents of the index folder of the
collection.
- You have a program open with a file from the index folder of the
collection loaded.
- The index directory contains read-only files or other files that the
GLI doesn't have permission to delete.

You should check these carefully if the error happens again.

Finally, there is an easy way of totally avoiding this problem: install
Apache and use the Web Server version of Greenstone. Installing and
configuring Apache isn't difficult (there is a section at the end of the
Greenstone Installer's Guide about this) and everything is much more
pleasant without the Local Library to worry about. If you're at all
serious about Greenstone, you'll want to use the Web Server version
eventually.

Regards,

Michael

Chaitra Rao wrote:

>Hi,
> I'm running gs v2.52 on my m/c. I need to make a collection out of a zip
>file(size -926 Kb). When I build the collection,it throws an error which
>says that "Exception detected during colleciton install.Most likey caused
>by Windows or local libraray holding locks on files:Index dir could not
>be removed..."
> I have to manually remove the indexes to build the collection again.
>However,the collection builds successfully when I build for the first
>time and after deleteing the indexes from coll_name/index/assoc.
> Please help asap!
>
>Regards,
>Chaitra
>
>
>_______________________________________________
>greenstone-users mailing list
>greenstone-users@list.scms.waikato.ac.nz
>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>
>