Re: [greenstone-users] after upgrading to 2.73 : HTTP error 500, classinfo.pl and pluginfo.pl failing

From Qiu
DateWed, 18 Jul 2007 10:08:04 +1200
Subject Re: [greenstone-users] after upgrading to 2.73 : HTTP error 500, classinfo.pl and pluginfo.pl failing
In-Reply-To (2565E01359FD0D46BF85F248E7A86AE8175257-inasp-server2-inasp-dnsalias-com)
Hi Egbert

Please replace two files attached to GSDLHOME/perllib, and run the
remote gli again. Let me know any problems.

Regards
Quan

Egbert de Smet wrote:

>Hi,
>
>after I upgraded from version 2.72 to 2.73 I cannot access my collection anymore using the remote client GLI with the server running on Debian. On my local version (also upgraded) it works fine still.
>The following error info is issued after I logged in using the remote GLI :
>
>Server returned HTTP response code: 500 for URL(...)/cgi-bin/gliserver.pl?cmd=get-script-options&script-classinfo.pl&xml=&language=en&listall&un=...
> [sorry but I left out my server and login data]
>Unable to get the list of classifiers using classinfo.pl -listall.
>
>Same errors repeat with pluginfo.pl instead of classinfo.pl.
>
>Is this part of the being 'unstable' of 2.73 ? Or should I look at another possible explanation ?
>
>Egbert
>
>
>------------------------------------------------------------------------
>
>_______________________________________________
>greenstone-users mailing list
>greenstone-users@list.scms.waikato.ac.nz
>https://list.scms.waikato.ac.nz/mailman/listinfo/greenstone-users
>
>


<<attachment>>
Type: application/x-perl
Filename: classify.pm

download


<<attachment>>
Type: application/x-perl
Filename: plugin.pm

download